Re: [csswg-drafts] [css-values] Automatic parsing of value definitions (#2921)

I see. `function` is intented to avoid a name clash between `<type()>` and `<type>`, or `value()` and `value`.

`w3c/reffy` extracts `<type()>` as a `type`, not as a `function` like Bikeshed does. But it is not affected by name clashes.

---

When you define [`minmax(min, max)`](https://drafts.csswg.org/css-grid-2/#funcdef-grid-template-columns-minmax) as a `function`, it is interpreted and extracted like if `minmax() = minmax(min, max)` were present in the specification, whereas the appropriate value definition depends on the context (`<track-size>` or `<fixed-size>`).

However, some functions are context-free but are only defined with `fn() = fn(...)`, or just `fn(...)`. They are extracted as `function`s by `w3c/reffy`, which means it is impossible (for me) to differentiate them from `minmax(min, max)`. 

I need to resolve `<fn()>` into `fn(...)` when I am parsing `<fn()>`, ie. I need to find a `type` definition in `w3c/reffy` data, whose name is `<fn()>`. I never need to resolve `minmax()`.

-- 
GitHub Notification of comment by cdoublev
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/2921#issuecomment-1857619085 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Friday, 15 December 2023 10:18:01 UTC