Re: [csswg-drafts] [css-shared-element-transitions-1] Renaming and brevity (#7788)

As others mentioned before, naming those pseudo-elements and the API just "view" might be too general and may lead to confusions with other features. Reading the initial renaming proposal, I immadiately thought: Why is "transition" not part of their names anymore when that's the whole point of this feature? And we are defining views that are transitioned, so maybe it should rather be "transition view"?
So my take on that would be to always have `transition-view-*` as a prefix. I.e.

> `page-transition-tag` becomes `view-name`

`transition-view-name`

> `html::page-transition` becomes `html::view-root`

`html::transition-view-root`

> `html::page-transition-container(header)` becomes `html::view(header)`

`html::transition-view(header)

> `html::page-transition-image-wrapper(header)` becomes `html::view-image-group(header)`

`html::transition-view-image-group(header)`

> `html::page-transition-outgoing-image(header)` and `html::page-transition-incoming-image(header)` become `html::view-before(header)` and `html::view-after(header)` respectively

`html::transition-view-before(header)`
`html::transition-view-after(header)`

> `document.createTransition()` becomes `document.createViewTransition()`

`document.createTransitionView()`

Note that I am totally aware that this makes the names mostly even longer than the original ones. Though I believe that clarity has higher priority than brevity.

Sebastian

-- 
GitHub Notification of comment by SebastianZ
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/7788#issuecomment-1260028383 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Tuesday, 27 September 2022 20:44:55 UTC