Re: [csswg-drafts] [selectors] Add pseudo-classes for `<select>` being a drop-down box vs a list box (#7422)

It seems to me that if this is only ever going to apply to `<select>`, then it should have "select" in the name. Otherwise, this feels confusing:

```css
input[type=date]:has-dropdown { doesn't match, even when the date picker "drop down menu" is present }
```

As for `:has-dropdown` and `:no-dropdown` - isn't that exactly why we have `:not()`, to avoid the need for that?

I vote for `:select-with-dropdown`, because "with" indicates the `<select>` comes with a drop-down. Somehow (and I'm not sure why) but `:select-has-dropdown` sounds to me like it should apply only when the dropdown is open. Like it **currently** has a dropdown.

Interesting side reading on "drop-down" vs "dropdown": https://www.chicagomanualofstyle.org/qanda/data/faq/topics/HyphensEnDashesEmDashes/faq0153.html. Perhaps we should use "menu" instead?

-- 
GitHub Notification of comment by mfreed7
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/7422#issuecomment-1208373469 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Monday, 8 August 2022 16:57:51 UTC