Re: [csswg-drafts] [selectors] Add pseudo-classes for `<select>` being a drop-down box vs a list box (#7422)

I don't think "menu" distinguishes `<select>` vs `<select size=5>`. The name here is also "for developers", so we're good per the Microsoft Writing Style Guide. :-)

`:not()` indeed allows the same expressiveness, but it's a bit more cumbersome compared to using a direct pseudo-class. Compare with

```
:link { ... }
:visited { ... }
```
vs
```
:any-link:not(:visited) { ... }
:visited { ... }
```

-- 
GitHub Notification of comment by zcorpan
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/7422#issuecomment-1208434606 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Monday, 8 August 2022 17:58:00 UTC