Re: [csswg-drafts] [css-shapes] Allow CSS grammar for path shapes (#5674)

> I find the functional notation (move(), line(), etc.) MUCH easier to read that the single letters. I pretty much hate the single letters, and they are not CSSy. Could we have those functions as the outer value, and NOT embed them in another function like shape()?

It's possible, but not sure how to represent the initial parameters in this case (fill-rule and starting-point).

An example in the current PR looks something like the `gradient` functions:
`clip-path: draw(evenodd, from 50% 100px, hline by 80px, vline to var(---height);`

If you remove the `draw()` function and use functions, it wold look like:

`clip-path: evenodd, from 50% 100px, hline(80px), vline(var(--height)), ...);`

Or if you make it more like `transform`, it would look like:

`clip-path: fill-rule(evenodd) from(50% 100px) hline(by 80px) vline(to var(--height)) ...);`

I like how the second one looks, but it also feels like it's inconsistent with the other shapes which have their own functions, which makes `draw` feel like a "special" shape (maybe it is?)


-- 
GitHub Notification of comment by noamr
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/5674#issuecomment-727523030 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Sunday, 15 November 2020 06:28:04 UTC