Re: [csswg-drafts] [css-inline] inline-sizing property name is too similar to inline-size (#5189)

> Would it make sense to call the `box-decoration-cross-size`?

I like the way you're thinking about this. `box-decoration-*` seems promising to me. For the `-cross-size` part, I'd be tempted to simplify to `-height`. It's a little bit less accurate, because height is typically meant in the physical sense, and here we're talking about logical height, but:
- It's so much shorter
- In this particular context, it's not ambiguous, since there's no corresponding property in the other axis
- There's precedent for primarily physical keywords being used in a logical sense when non ambigous: `vertical-align`. Even better, that precedent is on another property concerned with inline layout, so in terms of mental model, it's not particularly jarring.

TL;DR: I'd go with `box-decoration-height`

GitHub Notification of comment by frivoal
Please view or discuss this issue at using your GitHub account

Received on Tuesday, 21 July 2020 02:24:28 UTC