Re: [csswg-drafts] [css-sizing] Adding a 'size' shorthand for 'width'/'height' (#820)


> this approach would not cause any breaking changes for authors at all.

Afaict, the change is _not_ breaking since `size` inside `@page` will _continue_ to work for the purpose of backward compatibility, effectively being an _alias_ for the new `page-size`:

> Also defining that size in the page context parses into page-size

Still, I agree that renaming `size` to `page-size` is probably not necessary, given that `size` meaning inside `@page` rules is similar to its new meaning for regular elements, and especially given that `size` and `page-size` are going to be interchangeable inside `@page` _anyway_, so adding `page-size` probably just bloats the CSS keyword list.

GitHub Notification of comment by Marat-Tanalin
Please view or discuss this issue at using your GitHub account

Received on Monday, 21 October 2019 16:30:16 UTC