Re: [csswg-drafts] [web-animations-1] Replace AnimationEffectTiming(ReadOnly) with setTiming() ?

> @birtles The way I thought it differed was that you could pass an imcomplete set of properties and not have to start from the output of getTiming() first.

@graouts Oh sorry, no the WebIDL lets you pass an incomplete set of properties (that's what the very confusing `partial` naming was supposed to convey). So I think we're on the same page here.

> As for the name, `setTiming()` still sounds to me like we're replacing all properties, while `updateTiming()` indicates select properties can be set.

Ok, I can live with `updateTiming()`. I'd rather keep these names short, if possible, so I'd prefer not to add `Properties` to the end.

Just a thought, does `changeTiming()` make any sense? The reason is I'm currently working on the name for the method to update the playback rate while maintaining the current time and I'm wondering if `changePlaybackRate()` makes sense. I'm not sure why, but `updatePlaybackRate()` feels clunky somehow.

> @flackr I don't think there is a clear enough difference just by looking at names between `.timing`, `getTiming()` and `getComputedTiming()`.

I wonder what you think about modifying @flackr's proposal to include just `getTiming()` and `getComputedTiming()` (i.e. no `.timing`). It would avoid the awkwardness of having `getTiming()` return `duration` AND `computedDuration`, not to mention returning `duration` (a specified value) AND `activeDuration` (a computed value).

GitHub Notification of comment by birtles
Please view or discuss this issue at using your GitHub account

Received on Wednesday, 17 January 2018 22:47:57 UTC