Re: [csswg-drafts] [selectors4] Name the “functional pseudo-class like :matches() with 0 specificity”

@inoas, AFAIK, `:matches()` is not just "short-lived short-lived vendor implementation". It has been in the standard draft [for years]( (although the definition has changed a little), and its shipped implementation, without any flag/prefix, [has existsed since mid-2015]( (deprecating the old vendor-specific `:-webkit-any()` implementation), and there is intent to implement it in Blink ([1](!topic/blink-dev/kqD_G4sxfZE), [2]( So there should be some really solid reasons to rename/alias it (IMO).

Hovewer, I agree with Tab that the potential confusion in meaning between `:matches()` and `:is()` is not a very important issue. So I'm also fine with the both options — either introducing `:is()` as a functional analog for `:matches()` that **i**gnores **s**pecificity (as currently specified), or "overloading" `:matches()` with an optional extra argument, without adding new pseudo classes at all.

GitHub Notification of comment by SelenIT
Please view or discuss this issue at using your GitHub account

Received on Wednesday, 3 January 2018 07:59:11 UTC