Re: [csswg-drafts] [selectors4] Name the “functional pseudo-class like :matches() with 0 specificity”

In the past we would only not make changes because they'd break web compat. Now we're not making changes to not be "rude" to implementors? What fresh hell is this?! 😛 

`:matches()` has shipped in one browser and is not used by anyone. Renaming things is typically easy for implementors, and since nobody uses it (outside of postCSS) it doesn't break web compat.

What troubles me more is that I expect `:is()` to be used many more times in a selector and the lengthier `:matches()` would end up messing with readability. `:matches()` is only used for > 1 alternatives, whereas `:is()` is useful for singular things too. I think a name for `:is()` that's longer than 2-3 characters would be a pain.

GitHub Notification of comment by LeaVerou
Please view or discuss this issue at using your GitHub account

Received on Wednesday, 3 January 2018 15:22:58 UTC