Re: [csswg-drafts] [selectors4] Name the “functional pseudo-class like :matches() with 0 specificity”

Aliasing `:matches()` doesn't do much of value; the name as it stands is fine, so it's not worth adding yet another name for the same functionality. That just makes it harder to teach and understand.

Renaming `:matches()` is rude to the implementors at this point, and to the authors who've already learned it. We've had the function for a long time, implementors have begun implementing with it. If the name was truly bad or misleading we could *probably* rename it, but it's not - at worst, it's slightly annoying that `:is()` appears to be a slightly better antonym to `:not()` than `:matches()` is, so people new to the feature might get confused, but it's quick to learn which is which.  At this point in the feature's maturity, I don't think this justifies making a name change.

GitHub Notification of comment by tabatkins
Please view or discuss this issue at using your GitHub account

Received on Wednesday, 3 January 2018 03:52:05 UTC