Re: [csswg-drafts] [css-timing] reconsider name of frames() timing function

I think you want the space [distribution keywords](https://drafts.csswg.org/css-align-3/#distribution-values): space-around, space-between, space-evenly. Or alternately replace "space" with something else (maybe "pause" or "fill"), but certainly we should follow this existing pattern as it's both clear and consistent.

Imho, the following is pretty clear:
```
steps( [ <integer> || [ fill-start | fill-end | fill-evenly | fill-between | fill-around ] ] )
```
The number of steps is just as if your graph were the floor: there is one step if there is one jump, and there are two surfaces, one lower, one higher. How the steps are distributed in time (or space, if we re-use these functions for gradients) is using the keywords we are familiar with from Grid/Flexbox/Align. The addition of fill-start and fill-end allows for the asymmetric options: fill-start fills before the first step as it does between them, and fill-end fills after the last step as it does between them.

I understand the desire for frames(), but I don't think having a completely unrelated name for a function that is almost exactly the same as one that exists, but slightly different, is particularly helpful. (It'd be like adding :nth-index() so we could have zero-indexed :nth-child().) We've already chosen to count the steps rather than the frames, seems we should just continue on that path. I think the behavior expressed is particularly clear by maintaining the analogy to physical steps, fwiw.

-- 
GitHub Notification of comment by fantasai
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/1301#issuecomment-311773586 using your GitHub account

Received on Wednesday, 28 June 2017 20:08:35 UTC