Re: [csswg-drafts] [css-timing] Rename spec and wording to be more generic

I prefer "easing function", too.  It is a widely used term in animation, but is not explicitly limited to animation.  

"Interpolation function" is more generic, and also widely used, but "easing" has the benefit of being shorter.

I'd recommend against inventing new names (like "progression function") for existing concepts.  "Transition function" would be nice if we didn't already have a specific concept of CSS Transitions; but as is, I agree that it is useful to keep the concepts distinct.

For the spec name, I'd prefer CSS Easing Functions compared to CSS Easings Module (but css-easing for short).

GitHub Notification of comment by AmeliaBR
Please view or discuss this issue at using your GitHub account

Received on Tuesday, 11 July 2017 00:55:04 UTC