Re: [csswg-drafts] [css-timing] Rename spec and wording to be more generic

> Easing, though, and is a cross-industry standard term from motion design to studio animation, used wherever rates of visual change over time need describing. People using JS animation libraries use this term. I don't see why we should confuse them with yet another word for something they grok already. I'd keep "timing functions" over adopting "progression" or such.

The point of generalizing the name is that the functions are expected to be available outside of animation contexts in the future. Keeping the name for those contexts is confusing.

> "Interpolation function" is more generic, and also widely used, but "easing" has the benefit of being shorter.

"Interpolation" sounds really good to me, but I could live with "easing" as well.


GitHub Notification of comment by SebastianZ
Please view or discuss this issue at using your GitHub account

Received on Tuesday, 11 July 2017 12:31:11 UTC