Comments on VehicleInterface and Availability (Vadim's proposal)

The VehicleInterface section splits up the one interface into 3:

VehicleInterface, that has get(),
VehicleConfigurationInterface, that is used to signify attributes that
will never change and cannot be set()
VehicleSignalInterface which has set() and subscribe().

This generally looks good to me.

The Availability section adds a couple granular availability methods
to VehicleInterface(s).  Question: Why do the methods have an
"DOMString attributeName" argument?  This might be a typo because in
the examples those are absent.

The usage of "Retrieval" might be worded "Get" for consistency, but
this is probably a bikeshedding issue.

It also adds a callback mechanism in case availability changes.  This
makes sense.  The only issue I could come up with is the naming of
"ChangedListener".  I wonder if we should change the name of
subscribe() to dataChangedListener() again for consistency purposes.
"ChangedListener" is probably a more common pattern in the w3c and
other APIs.


Received on Wednesday, 11 June 2014 21:05:50 UTC