W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2012

[Bug 20505] merge getInput, getOutput -> getPort() or getPortById()

From: <bugzilla@jessica.w3.org>
Date: Wed, 26 Dec 2012 15:27:24 +0000
To: public-audio@w3.org
Message-ID: <bug-20505-5429-mRtyLzKBTp@http.www.w3.org/Bugs/Public/>

--- Comment #4 from Marcos Caceres <w3c@marcosc.com> ---
(In reply to comment #3)
> (In reply to comment #2)
> > It would be especially
> > annoying if faced with a UA that doesn't have enough data to give reliable
> > fingerprints, an application would've stored a fingerprint and assumed that
> > the method would return an output port, but was given an input port instead,
> > resulting in an error if it tried to send anything to it.
> Agreed. But as I said above, at this stage in the standardisation game, it
> does not hurt to see if that problem can be solved somehow. 
> Having said that, we should add a big red note to the spec asking
> implementers for feedback exactly about this.

Just wanted to record a random thought here:

getPort(DOMString id, optional MIDIPortType type);

As in: 
var port = midi.getPort("12e23f3", "input");

You are receiving this mail because:
You are the QA Contact for the bug.
Received on Wednesday, 26 December 2012 15:27:26 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:03:15 UTC