W3C home > Mailing lists > Public > public-aria-editors@w3.org > November 2016

Re: APG build fail

From: Michael Cooper <cooper@w3.org>
Date: Tue, 8 Nov 2016 09:35:39 -0500
To: Michiel Bijl <michiel.list@moiety.me>, Matt King <a11ythinker@gmail.com>
Cc: ARIA Editors <public-aria-editors@w3.org>
Message-ID: <eb79f5c0-c239-07c1-bb1d-852b96b4e9c0@w3.org>
I believe this is related to the sporadic non-functionality of Respec 
that I've been seeing for weeks now. Shane has worked with the systems 
people on this, and they did something to make it happen less often, but 
it still happens. In particular, it seems that to get respec-enabled 
documents to display properly in some browsers it requires a refresh 
[Chrome] (in other browsers [Firefox] even that doesn't work and it's 
just random luck as to whether Respec works). Because the spec-generator 
service doesn't refresh, it just fails. Shane said the spec-generator 
doesn't use a browser, but it does seem to me to fail in the same 
frequency that browsers do

I still don't know what is causing the failure - a change in browser 
security models, some subtle thing in the source of our documents that 
isn't obvious, a change to W3C anti-denial of service practices, some 
strange bug in Respec - so I haven't known who to file a bug report 
with. Shane's attempt to work with the W3C systems people seems to have 
produced some results but not resolved the problem; I believe they're 
having a hard time duplicating the problem even though I see it on 
nearly every document I work with.

I've been thinking of trying to come up with a workaround to this, by 
including Respec as a library in our repositories rather than pointing 
to its location on the W3C server, but until I get the aria-common 
library working I won't know how to make that work. I've also thought of 
trying to install the spec generator locally within the build script 
rather than rely on the online version (that fails a lot in the best of 
circumstances), but the documentation is atrocious and I can't figure 
out how to get started. It's all on my todo list, and perhaps I need to 
escalate with more knowledgeable people.

In the meantime, since the problem seems to be sporadic, you can always 
try to restart the build. For practices, go to 
https://travis-ci.org/w3c/aria-practices/ and hit "Restart build". I 
just tried this and it didn't work, but sometimes I have seen it work.

Michael


On 08/11/2016 8:32 AM, Michiel Bijl wrote:
> Hi,
>
> Ever since pull request #147 
> <https://github.com/w3c/aria-practices/issues/147> was merged into 
> master the build is failing again. I’m not quite sure how to fix this, 
> but could somebody look at it? If you know what it is I’d love to 
> learn for next time this happens.
>
> —Michiel
>
Received on Tuesday, 8 November 2016 14:35:48 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 8 November 2016 14:35:49 UTC