W3C home > Mailing lists > Public > public-annotation@w3.org > November 2016

Re: Annotation Model Reports updated

From: Shane McCarron <shane@spec-ops.io>
Date: Fri, 25 Nov 2016 11:02:00 -0600
Message-ID: <CAJdbnOCtgXwrOk=YeaZqzpRh9a-3EALRVPqLqU81xKPjDhUMVw@mail.gmail.com>
To: Robert Sanderson <azaroth42@gmail.com>
Cc: W3C Public Annotation List <public-annotation@w3.org>
Yeah I noticed that things seemed wrong. I also noticed that the tests on
w3c-test.org are NOT the same as the ones on my server.  And the ones on my
server are from the PR I am sure we submitted so... I have no idea what is
going on.

On Thu, Nov 24, 2016 at 2:48 PM, Robert Sanderson <azaroth42@gmail.com>
wrote:

>
> Collection Musts 1:3 seems buggy.  Everyone suddenly started failing
> AnnotationCollection in the type of the Collection?
> Also Page Musts 1:2 through 1:8 ... same deal.
>
> Then the page optionals I think are wrong too ... I know that my
> implementation has partOf, next and prev which aren't in the table.
>
> Finally total isn't a property of a Page, it's a property of the
> Collection, and thus shouldn't be tested (page optionals 1:7)
>
> Rob
>
>
>
> On Thu, Nov 24, 2016 at 12:31 PM, Shane McCarron <shane@spec-ops.io>
> wrote:
>
>> I re-ran the tests using an automated script against the latest tests.  I
>> also integrated the new inputs from Janina J.  The reports are at [1]
>>
>> [1] https://w3c.github.io/test-results/annotation-model/all.html
>>
>> --
>> Shane McCarron
>> Projects Manager, Spec-Ops
>>
>
>
>
> --
> Rob Sanderson
> Semantic Architect
> The Getty Trust
> Los Angeles, CA 90049
>



-- 
Shane McCarron
Projects Manager, Spec-Ops
Received on Friday, 25 November 2016 17:03:00 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:54:50 UTC