Bikeshedding Digest Field names

Hello HTTP WG,

Following the last interim meeting and discussion on Github, we've merged
the proposal that switches to Structured Fields.

There is now a matter of bikeshedding their names to resolve. On issue
#1966 [1] I laid out the status quo and some of the suggestions made during
the interim. There was also some further discussion on the issue. Now I
just want to promote the topic on the list to see if there is any more
constructive input.

So far we seem happy to:

* stick with `Content-`
* stick with `Want-` prefixes, where they apply

We probably want to rename `Representation-`:
  * `Repr-` seems like a something people can get behind

There has been a suggestion to rename the suffic `-Digest` to `-Hash`.
Personally I don't see the need to do that (and some churn if we did) but
I'd be interested in hearing if there is other support or resistance.

Responses preferred on the Github issue [1].


[1] -

Received on Tuesday, 1 March 2022 17:28:45 UTC