W3C home > Mailing lists > Public > www-webont-wg@w3.org > September 2002

Re: oneOf (2.4)

From: Peter F. Patel-Schneider <pfps@research.bell-labs.com>
Date: Wed, 11 Sep 2002 14:43:58 -0400 (EDT)
Message-Id: <20020911.144358.107982143.pfps@research.bell-labs.com>
To: ewallace@cme.nist.gov
Cc: www-webont-wg@w3.org

From: Evan Wallace <ewallace@cme.nist.gov>
Subject: Re: oneOf (2.4)
Date: Wed, 11 Sep 2002 14:37:02 -0400 (EDT)

> Dan Connolly responded to Ian's comments on oneOf with:
> >>Yes, it's not clear that the improvement justifies the cost
> >>of the change... raising an issue and all that...
> >
> It doesn't seem a very high cost to me.  Anything that makes the
> language more accessible to users is well worth the effort.  Should
> I propose a new issue on this or can we cover it with an old one?
> BTW - I have always found oneOf to be a misleading name for this
> construct, whereas enumeratedClass identifies its purpose nicely for me.
> -Evan

There are two problems with using enumeratedClass:
1/ EnumeratedClass is the token used to define top-level enumerated classes
   in the abstract syntax.
2/ ...Class is better reserved for tokens that define top-level classes,
   not descriptions.  

If a name change is needed, I would prefer owl:enumeration.

Received on Wednesday, 11 September 2002 14:44:08 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:56:47 UTC