W3C home > Mailing lists > Public > www-webont-wg@w3.org > September 2002

Re: oneOf (2.4)

From: Ian Horrocks <horrocks@cs.man.ac.uk>
Date: Thu, 12 Sep 2002 00:12:53 +0100
Message-ID: <15743.52725.775959.851977@merlin.oaklands.net>
To: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>
Cc: ewallace@cme.nist.gov, www-webont-wg@w3.org

On September 11, Peter F. Patel-Schneider writes:
> 
> From: Evan Wallace <ewallace@cme.nist.gov>
> Subject: Re: oneOf (2.4)
> Date: Wed, 11 Sep 2002 14:37:02 -0400 (EDT)
> 
> > 
> > 
> > Dan Connolly responded to Ian's comments on oneOf with:
> > >>Yes, it's not clear that the improvement justifies the cost
> > >>of the change... raising an issue and all that...
> > >
> > 
> > It doesn't seem a very high cost to me.  Anything that makes the
> > language more accessible to users is well worth the effort.  Should
> > I propose a new issue on this or can we cover it with an old one?
> > 
> > BTW - I have always found oneOf to be a misleading name for this
> > construct, whereas enumeratedClass identifies its purpose nicely for me.
> > 
> > -Evan
> > 
> 
> There are two problems with using enumeratedClass:
> 1/ EnumeratedClass is the token used to define top-level enumerated classes
>    in the abstract syntax.
> 2/ ...Class is better reserved for tokens that define top-level classes,
>    not descriptions.  
> 
> If a name change is needed, I would prefer owl:enumeration.

I suggested enumerationOf because other properties of this kind end in
"Of", e.g., intersectionOf, unionOf etc.

Ian

> 
> peter
> 
Received on Wednesday, 11 September 2002 19:15:39 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:52 GMT