W3C home > Mailing lists > Public > www-webont-wg@w3.org > September 2002

Re: oneOf (2.4)

From: Dan Connolly <connolly@w3.org>
Date: 11 Sep 2002 13:21:45 -0500
To: Ian Horrocks <horrocks@cs.man.ac.uk>
Cc: www-webont-wg@w3.org
Message-Id: <1031768505.2992.3565.camel@dirk>

On Wed, 2002-09-11 at 11:50, Ian Horrocks wrote:
> On September 9, Dan Connolly writes:
> > On Sun, 2002-09-08 at 14:38, Ian Horrocks wrote:
[...]
> > > I find myself less and less satisfied with "oneOf" as the name given
> > > to extensionally defined classes.
[...]
> > I don't see how you can use a class name name like EnumeratedClass
> > to relate a class to its members. How would this work
> > in the exchange syntax?
> 
> OK - you could call it enumerationOf then.

Yes, that's an improvement.

> This seems more consistent
> and readable. To me, "oneOf" makes it sound as though the class being
> defined consists of just one of the enumerated elements when in fact
> it consists of all of them. E.g., someValuesFrom oneOf (x y z) might be
> taken to mean that all instances of the class must be related to the
> same object.
> 
> But it's not a big deal.

Yes, it's not clear that the improvement justifies the cost
of the change... raising an issue and all that...

Hmm... we already have a related issue...

http://www.w3.org/2001/sw/WebOnt/webont-issues.html#I2.4-Enumerated-Classes

but we closed it. The name is ironic, no?

Meanwhile, the ink isn't dry on the tests... Jim H. has
an action to make them.
http://lists.w3.org/Archives/Public/www-webont-wg/2002Jul/0276.html

Given that we're still working out some of the details of
this issue, I wouldn't mind changing the name while we're at it.

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
Received on Wednesday, 11 September 2002 14:21:45 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:52 GMT