W3C home > Mailing lists > Public > www-webont-wg@w3.org > September 2002

Re: oneOf

From: Ian Horrocks <horrocks@cs.man.ac.uk>
Date: Wed, 11 Sep 2002 17:50:48 +0100 (BST)
Message-ID: <15743.29800.926549.527984@excalibur.oaklands.net>
To: Dan Connolly <connolly@w3.org>
Cc: www-webont-wg@w3.org

On September 9, Dan Connolly writes:
> On Sun, 2002-09-08 at 14:38, Ian Horrocks wrote:
> > 
> > A minor point in comparison with some of the issues we are currently
> > wrestling with, but still...
> > 
> > I find myself less and less satisfied with "oneOf" as the name given
> > to extensionally defined classes.
> 
> Er... it's not a name given to any classes;
> it's a property that relates a class to a list of its
> members.
> 
> 	:MyBrothers :oneOf (:Paul :Jon).
> 
> i.e.
> 	<rdfs:Class rdf:ID="MyBrothers">
> 	  <owl:oneOf rdf:parseType="Collection">
> 	    <rdf:Description rdf:ID="Paul"/>
> 	    <rdf:Description rdf:ID="Jon"/>
> 	  </owl:oneOf>
> 	</rdfs:Class>
> 
> > After all, the resulting class
> > contains all of the enumerated individuals, not just one of
> > them. EnumeratedClass, as per the abstract syntax, seems much better.
> 
> I don't see how you can use a class name name like EnumeratedClass
> to relate a class to its members. How would this work
> in the exchange syntax?

OK - you could call it enumerationOf then. This seems more consistent
and readable. To me, "oneOf" makes it sound as though the class being
defined consists of just one of the enumerated elements when in fact
it consists of all of them. E.g., someValuesFrom oneOf (x y z) might be
taken to mean that all instances of the class must be related to the
same object.

But it's not a big deal.

Ian

> 
> -- 
> Dan Connolly, W3C http://www.w3.org/People/Connolly/
> 
> 
Received on Wednesday, 11 September 2002 12:58:51 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:52 GMT