Re: oneOf

On Sun, 2002-09-08 at 14:38, Ian Horrocks wrote:
> 
> A minor point in comparison with some of the issues we are currently
> wrestling with, but still...
> 
> I find myself less and less satisfied with "oneOf" as the name given
> to extensionally defined classes.

Er... it's not a name given to any classes;
it's a property that relates a class to a list of its
members.

	:MyBrothers :oneOf (:Paul :Jon).

i.e.
	<rdfs:Class rdf:ID="MyBrothers">
	  <owl:oneOf rdf:parseType="Collection">
	    <rdf:Description rdf:ID="Paul"/>
	    <rdf:Description rdf:ID="Jon"/>
	  </owl:oneOf>
	</rdfs:Class>

> After all, the resulting class
> contains all of the enumerated individuals, not just one of
> them. EnumeratedClass, as per the abstract syntax, seems much better.

I don't see how you can use a class name name like EnumeratedClass
to relate a class to its members. How would this work
in the exchange syntax?

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/

Received on Monday, 9 September 2002 09:52:55 UTC