W3C home > Mailing lists > Public > www-validator@w3.org > August 2002

Re: Validating my HTML code: background= problems

From: Terje Bless <link@pobox.com>
Date: Wed, 7 Aug 2002 02:37:19 +0200
To: Nick & Kate Nicholes <kghn@ttc-cmc.net>
cc: www-validator@w3.org
Message-ID: <r01050300-1015-EB13793EA9B911D6ACDF00039300CF5C@[193.157.66.10]>

Nick & Kate Nicholes <kghn@ttc-cmc.net> wrote:

>I am finding inconsistent error flagging behavior regarding the use of
>BACKGROUND="***.jpg".  It validates fine in a <BODY> command, flags as
>an error in <TABLE>, and *sometimes* is flagged as an error in <TD>.  I
>have swapped around similar <TR><TD BACKGROUND="***.jpg">***</TD><TR>
>table sections, and the first occurance is flagged and the second and
>subsequent are not. Also, if I duplicate the offending section, only the
>first occurance is flagged.

Quite apart from the excellent advice from Thanasis and Kynn, what you've
stumbled on is a known issue with the Validator; it will only report
certain classes of errors once. This can be pretty misleading and confusing
at times, but we haven't so far been able to track down the cause of this.


-- 
Yes, Micro$oft products work extremely well after you lobotomize yourself,
affect a zombie-like stare, and forever chant the "Micro$oft-knows-best"
mantra until your soul dissolves and you start believing all their crap.
Received on Tuesday, 6 August 2002 23:58:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:03 GMT