W3C home > Mailing lists > Public > www-validator@w3.org > February 2001

Re: Unix --> NT (source code stuff)

From: Brian Gilkison <gilkison@one.net>
Date: Tue, 27 Feb 2001 22:06:58 -0500
To: <www-validator@w3.org>
Message-ID: <NABBLPCLGCEADCFDBEICOEDACHAA.gilkison@one.net>
For those with NT concerns, I can say that the validator runs virtually
unchanged on my system: Win2000, Apache 1.3.17, Perl 5.6.0 (ActiveState
build 620) -- didn't even have to name it 'check.pl'!  The only thing I feel
I HAD to change in 'check' was the $abs_svc_uri and $logfile to point to
appropriate directories on my server; three additions to the httpd.conf file
for Apache; otherwise, I have nsgmls.exe, validator, etc. in a matching
directory structures, and it runs flawlessly.

With this exception -- not so much a flaw but perhaps an oversight?  When I
receive the output from a validation, IMG tags (for the valid logo), and
links on that pages are all hardcoded to either www.w3.org/icons/ or
validator.w3.org/images/ (and I'm not sure there's consistency in which
image location is used) ...  Perhaps this could be modified to point to
$abs_svc_uri$abs_svc_uri instead?  Specifically, I'm think of the hardcoded
URLs from line 667 to 714 in Revision 1.78 of the 'check' script (I'd
contribute via CVS, but that's one thing I've never gotten to work on my NT
box...)

Brian Gilkison
gilkison@one.net
Received on Tuesday, 27 February 2001 22:07:19 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:55 GMT