W3C home > Mailing lists > Public > www-validator@w3.org > January 1999

RE: Problems validating html40 strict

From: Allen Strand <astrand@ix.netcom.com>
Date: Fri, 22 Jan 1999 10:11:18 -0800
Message-ID: <01BE45EF.92CC10A0.astrand@ix.netcom.com>
To: "'Mustapha El Belghiti'" <mbelghiti@aei.ca>, "www-validator@w3.org" <www-validator@w3.org>
You missed the trailing quote after the EN on line one as
per the specification.  With only 3 " characters, I wouldn't
expect the validator to work correctly.  The correct syntax
is:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN"
            "http://www.w3.org/TR/REC-html40/strict.dtd">

I tried it at:
http://www.coaptive.com/test/test.html

Allen Strand

-----Original Message-----
From:	Mustapha El Belghiti [SMTP:mbelghiti@aei.ca]
Sent:	Friday, January 22, 1999 9:09 AM
To:	www-validator@w3.org
Subject:	Problems validating html40 strict

Hi folks,

 Why do I get an error when using the following doctype
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN
"http://www.w3.org/TR/REC-html40/strict.dtd"> 

The error is regarding "http://www.w3.org/TR/REC":
	name start character invalid: only delimiter ">",
          delimiter "[", system identifier and parameter separators are allowed


When I use <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">, I don't get
any errors.

This error occurs with my local version and with the online version.

Where's the problem, the catalog file or the check script?

Thanks in advance.

               ,,,
Received on Friday, 22 January 1999 13:16:54 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:51 GMT