W3C home > Mailing lists > Public > www-svg@w3.org > March 2008

Re: SVGt 1.2 Tests: animate-elem-41-t fill rule animation is incorrect and error in ref image

From: Dr. Olaf Hoffmann <Dr.O.Hoffmann@gmx.de>
Date: Thu, 6 Mar 2008 18:28:48 +0100
To: www-svg@w3.org
Message-Id: <200803061828.48896.Dr.O.Hoffmann@gmx.de>

1) Yes, I think, this is indeed a problem in SVGT1.2 and SMIL2.
The test was taken from the SVG 1.1 test suite, but
SVG 1.1 and the old SMIL animation recommendation provide
no direct information about the timing of such a to-animation.
At that time, it was a 'good' approach to assume the behaviour
as described. 
The problem with SMIL seems to be, that the normative  formula
is only usable for interpolable values and it is somehow uncertain,
if the example with the discrete to-animation is informative or
normative. Furthermore fill-rule can be assumed to be non-additive,
and there is still a minor problem with such animations in SMIL2.
This is solved in the current SMIL3 draft fitting to the example.

The simplest approach could be to replace it with a 
from-to-animation or values-animation, because I think, 
in this test is is not really intended to test such critical 
features like to-animations ;o)

2) Yes, the color looks wrong for me too ;o)
As far as I can see in my own tests, the tool used to
produce the PNGs has an implementation gap here -
therefore this image has to be created independently :-(

 
Received on Thursday, 6 March 2008 17:37:35 GMT

This archive was generated by hypermail 2.3.1 : Friday, 8 March 2013 15:54:38 GMT