W3C home > Mailing lists > Public > www-svg@w3.org > March 2008

SVGt 1.2 Tests: animate-elem-41-t fill rule animation is incorrect and error in ref image

From: Kalle Raita <kraita@nvidia.com>
Date: Thu, 6 Mar 2008 17:51:08 +0100
Message-ID: <85DD8D3F1695004A8A9A5AC16CE584BE05D1D474@deemmail01.nvidia.com>
To: <www-svg@w3.org>

Hi All,
 
In the SVGt 1.2 tests, the test animate-elem-41-t seems to have two
distinct problems in the beta release.

1) The animation of fill-rule has only 'to' value specified and the SMIL
spec states:
  "Since a to animation has only 1 value, a discrete to animation will
   simply set the to value for the simple duration."
Our interpretation is that then the fill-rule animation in the test
immediately sets the rule "evenodd"
and the "nonzero" rule is not in effect at any time, contrary to the
checking hints provided by the tests.

2) In the reference image the rectangle that has currentColor animated
is not of same color as the reference
rectangle above. Looking at the test sources they should have the same
fill color.

Yours, 
  - Kalle Raita 


Kalle Raita 
NVIDIA Corporation 
Tel. +358 40 723 1441 
kraita@nvidia.com 
http://eu.nvidia.com <http://eu.nvidia.com/>  

-----------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
-----------------------------------------------------------------------------------
Received on Thursday, 6 March 2008 16:51:48 GMT

This archive was generated by hypermail 2.3.1 : Friday, 8 March 2013 15:54:38 GMT