W3C home > Mailing lists > Public > www-svg@w3.org > December 2005

Re: SVG12: wheelDelta should be UIEvent.detail

From: Bjoern Hoehrmann <derhoermi@gmx.net>
Date: Thu, 29 Dec 2005 14:05:05 +0100
To: Chris Lilley <chris@w3.org>
Cc: www-svg@w3.org
Message-ID: <87n7r112mfcnonllannvkpqn7h5gcinp2t@hive.bjoern.hoehrmann.de>

* Chris Lilley wrote:
>BH>   http://www.w3.org/TR/2005/WD-SVGMobile12-20050413/svgudom.html
>BH> appendix A.4.10 proposes a new wheelDelta member; this is not needed,
>BH> as the event inherits from UIEvent it should re-use the existing
>BH> detail attribute. Please change the draft to this effect.

>The original design inherited from MouseEvent so detail was already
>used. We have since made it more generic so that it applies to jog dials
>and suchlike wheels as well; it now inherits from UIEvent. owever, after
>discussing your comment, we feel that wheelDelta is clearer and more
>self documenting than 'detail'. We plan therefore to keep wheelRotation,
>since it's a clearer name.

I don't think this is right decision; I am concerned that authors will
misremember the 'wheelDelta' name and mistype it as e.g. 'wheelRotation'
whereas the 'detail' name is easy to remember and consistent with e.g.
the mouse and time events. The implementation cost of re-using the de-
tail member is also lower than making up a new member and keeping the
then unused detail member.
Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de
Weinh. Str. 22 · Telefon: +49(0)621/4309674 · http://www.bjoernsworld.de
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/ 
Received on Thursday, 29 December 2005 13:04:49 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 March 2017 09:47:05 UTC