W3C home > Mailing lists > Public > www-lib@w3.org > July to September 2001

libapp_1.obj : error LNK2001: unresolved external symbol _HTLibTerminate

From: Bathal Raghavendra <raghu@adroit-tech.com>
Date: Mon, 2 Jul 2001 13:07:30 +0100
Message-ID: <007b01c102ef$91922d40$a2a1fed5@adroit>
To: <www-lib@w3.org>
Hi All,
I tried work with Libwww.
1) My machine is having windows 98.
2) I installed WinCVS1.2 from GNU
3) Installed LiteWebServer from www.gefionsoftware.
4) Did anonymous check out of all the files at
http://www.w3.org/Library/cvs.html
5) .cvspass file exists in C:\
6) Getting Boot strapped...
    a)INstalled perl from
www.aspn.activestate.com/aspn/downloads/ActivePerl/
      ran the perl command...
    % cd libwww
    % perl config/winConfigure.pl
    but got the error message  'File Creation Failed'....

    b)Went to section "how to compile libwww for Windows. "
    c) Downloaded the latest MSVC makefiles..and copied files to the
corrending directory structure under Libwww folder.
    d) ran perl command again and got the same error message.'File Creation
Failed'....


7) Now,,,statred  LiteWebServer
8) Using VC++, tried to run post.c... i got the message files not found...SO
I copied all header files to program files>>visual Studio >> vc98>>includes.
    So problem was over.
9) But i get some link problems.The i ran the simplest of programs
libapp_1.c
and this the error messages...
--------------------Configuration: libapp_1 - Win32
Debug--------------------
Linking...
libapp_1.obj : error LNK2001: unresolved external symbol _HTLibTerminate
libapp_1.obj : error LNK2001: unresolved external symbol _HTLibInit
Debug/libapp_1.exe : fatal error LNK1120: 2 unresolved externals
Error executing link.exe.

libapp_1.exe - 3 error(s), 0 warning(s)
-------------------------------------------------
What is the problem?
Can any one help me on setting the system so that i can start using the
samples programs and...
Tnx in advance,
Cheers,
Raghu
Received on Monday, 2 July 2001 08:06:33 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:39 GMT