W3C home > Mailing lists > Public > www-lib@w3.org > April to June 1999

RE: Building libwww under MSVC

From: Vladimir Kozlov <Vladimir.Kozlov@idm.ru>
Date: Mon, 5 Apr 1999 09:42:41 +0400
Message-ID: <6174667DA154D211BA2D00A0C9292CCB01B930@E0-IDM.r.miee.ru>
To: Henrik Frystyk Nielsen <frystyk@w3.org>
Cc: www-lib@w3.org
Henrik, Jim,

Three days ago (at April, 2) I've recompile all libwww using the same
mechanism without any problem.

Kind regards,

Vladimir Kozlov.

-----Original Message-----
From: Henrik Frystyk Nielsen [mailto:frystyk@w3.org]
Sent: Friday, April 02, 1999 9:16 PM
To: Jim_Ravan@avid.com; www-lib@w3.org
Subject: Re: Building libwww under MSVC

At 11:14 4/2/99 -0500, Jim_Ravan@avid.com wrote:
>Did I do this correctly? In order to compile the latest CVS libwww
>Windows NT, I downloaded
>http://www.w3.org/Library/Distribution/libwww-win32.zip. Then I
unzipped it
>into the libwww directory. Then I used the world.dsw workspace to
>everything. This seemed to be the correct thing to do and it seemed to
>mostly work. I was confused by the comment on
>http://www.w3.org/INSTALL.html#Windows that said:
>     "If using the CVS tree, then you can get a version which is in
>with the latest CVS sourcetree."

I agree that it was confusing - I have tried to make it clearer - from:


it now says:

You can also get the latest MSVC makefiles (PGP signature) which are in
sync with the current CVS source tree (not the distribution package!).
makesfiles are not in CVS themselves as they constantly cause CVS
conflicts. Unzip them on top (directly in the libwww folder) of your
checked out CVS tree and repeat the bootstrap mechanism.

>Unfortunately, there is no further comment as to how to get the MSVC
>workspace and projects from CVS. They don't seem to come automatically
>doing a checkout of libwww. Is there a way to get them from CVS?

No, I had to remove them because they constantly cause conflicts because
the way they are generated.

>Also, the current dsw package seems to be MSVC Version 5. Is this
>If so, why does MSVC complain as follows?
>     Command line warning D4002 : ignoring unknown option '/ZI'

Yes it is MSVC 5.0 - I have no idea why it complains about this. 

>Further, I tried to convert the world.dsw workspace to MSVC Version 6
>format, but was unable to do to so. After converting all the projects,
>complained that the workspace could not be modified due to a "sharing
>violation". Can anyone explain this?

The workspace was created in MSVC 5.0 and I haven't messed with it at
so I don't know why it can't be converted. Does it mean that you can't
the workspace at all?

Has anyone else seen this? 

Henrik Frystyk Nielsen,
World Wide Web Consortium
Received on Monday, 5 April 1999 01:44:06 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:33:49 UTC