W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 1997

Missing files and sub-directories of a directory

From: Anselm Baird_Smith <abaird@www43.inria.fr>
Date: Mon, 24 Feb 1997 09:44:22 +0100 (MET)
Message-Id: <199702240844.JAA03736@www43.inria.fr>
To: Stuart Powell <stuartp@in.ot.com.au>
Cc: www-jigsaw@w3.org
Stuart Powell writes:
 > Hi,
 > 
 > I'm running Jigsaw 1.0alpha5 on a Sun Solaris 2.5.1 Ultra SPARC system and
 > I'm having trouble with DirectoryResources not finding their child files and
 > directories.
 > 
 > I have the following directories loaded under root.
 > 
 > <root>
 >   |
 > <users>    This is a PassDirectory to /home/users on our system.
 >   |
 > <stuartp>  DirectoryResource for my home directory, which is read-only 
 >   |        but executable to others to allow searches.
 >   |
 > <www>      DirectoryResource: added manually, since Jigsaw didn't have
 >   |        read permission to scan the UNIX directory.
 >   |
 > <java-grid>  DirectoryResource: automatically found by Jigsaw.
 > 
 > Under java-grid there are 3 sub-directories and 5 files.  One of the
 > sub-directories is a UNIX symbolic link (though I haven't found this a
 > problem before with Jigsaw).
 > 
 > Jigsaw automatically sees 2 of the directories (not the sym link one) and
 > only one of the files.  Even if I add the sym link directory manually
 > (through the resource editor),  it doesn't pick up sub-directories or files
 > under this directory.  I've checked that all the resources are marked
 > "extensible".  I have tried re-indexing and updating, removing and
 > reinstalling various directories in the path - all to no avail.  I've also
 > tried configuring the structure from scratch on a different server, but
 > there was no difference.  [Also running version 1.0alpha3 and running on
 > JDK1.1b3 did not help.]

One possibility: if you look at the pre-defined directory templates in
the sample config, you will see thaht there is only a WWW template. As
your users and stuartp directories don't fall under a WWW directory,
there is no templates for them. This means that they will be indexed
through a 'default' raw DirectoryResource. This may be the cause of
your troubles.

To check that this is the case, you could easily:
- move users and stuartp (or symlink) to WWW
- create an extra directory under root say 'extra' then a WWW
  directory, and finally put the two directories there.
- Create directory templates for stuartp and users

If you test any of these four possibilities with or without success,
let me know (they might be a bug hiding behind the scene here)

Thanks,
Anselm.

 > From my scanning of the code, the subdirectories and files should all be
 > picked up when the directory is indexed, but this doesn't seem to be
 > happening.  The error log has lines similar to the following:
 > 
 > "client-10: caught ClientException: [w3c.jigsaw.http.ClientException]
 > Resource temporarily unavailable"
 > 
 > but it's not clear that these are related to my problem.

I thought I got rid of those (perhaps after the release ?) "The trace
is the bug" ;-)

Anselm.
Received on Monday, 24 February 1997 03:44:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:26 GMT