W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 1997

Missing files and sub-directories of a directory

From: Stuart Powell <stuartp@in.ot.com.au>
Date: Fri, 21 Feb 1997 16:28:22 +1100
Message-Id: <1.5.4.32.19970221052822.006aff88@valentine>
To: www-jigsaw@w3.org
Hi,

I'm running Jigsaw 1.0alpha5 on a Sun Solaris 2.5.1 Ultra SPARC system and
I'm having trouble with DirectoryResources not finding their child files and
directories.

I have the following directories loaded under root.

<root>
  |
<users>    This is a PassDirectory to /home/users on our system.
  |
<stuartp>  DirectoryResource for my home directory, which is read-only 
  |        but executable to others to allow searches.
  |
<www>      DirectoryResource: added manually, since Jigsaw didn't have
  |        read permission to scan the UNIX directory.
  |
<java-grid>  DirectoryResource: automatically found by Jigsaw.

Under java-grid there are 3 sub-directories and 5 files.  One of the
sub-directories is a UNIX symbolic link (though I haven't found this a
problem before with Jigsaw).

Jigsaw automatically sees 2 of the directories (not the sym link one) and
only one of the files.  Even if I add the sym link directory manually
(through the resource editor),  it doesn't pick up sub-directories or files
under this directory.  I've checked that all the resources are marked
"extensible".  I have tried re-indexing and updating, removing and
reinstalling various directories in the path - all to no avail.  I've also
tried configuring the structure from scratch on a different server, but
there was no difference.  [Also running version 1.0alpha3 and running on
JDK1.1b3 did not help.]

From my scanning of the code, the subdirectories and files should all be
picked up when the directory is indexed, but this doesn't seem to be
happening.  The error log has lines similar to the following:

"client-10: caught ClientException: [w3c.jigsaw.http.ClientException]
Resource temporarily unavailable"

but it's not clear that these are related to my problem.

Am I doing something silly here or is this a bug of some kind?

Any help would be appreciated.

Regards,
Stuart Powell
--------------------------------------------------------------------------
 _--_|\   Stuart Powell   
/      \  IN Group, Open Technology     Email: stuart.powell@in.ot.com.au
\_.--._*  Level 12, 80 Mount St         Phone: +61 2 9929 8433           
      v   North Sydney 2060             Fax:   +61 2 9929 8477           
          AUSTRALIA                                                      
--------------------------------------------------------------------------
Received on Friday, 21 February 1997 01:06:51 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:26 GMT