W3C home > Mailing lists > Public > www-isaviz@w3.org > March 2002

Win98 SE - java.lang.NoClassDefFoundError

From: Ken Cotterill <ken@me.com.au>
Date: Tue, 19 Mar 2002 18:44:10 +1100
Message-ID: <008401c1cf19$dc6dcd00$baa711cb@deimos>
To: <www-isaviz@w3.org>
Dear List,

I've just installed IsaViz and encountered a problem running it for the first time.

Output from run.bat (between hashes):
###############################
C:\apps\IsaViz>java -classpath lib\isaviz.jar;lib\vtm.jar;lib\xerces.jar;lib\jena.jar org.w3c.IsaViz.Editor


Exception in thread "main" java.lang.NoClassDefFoundError: org/w3c/IsaViz/Editor
###############################

Binary files unpacked from: isaviz-bin-1_0.zip
Platform: Win98 SE
JRE: 1.4.0
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\J2SDK1.4.0\BIN

Before running I unpacked "graphviz1.8.2.zip" into "C:\apps\IsaViz\GraphViz".

I did try directly editing the XML in "isaviz.cfg":
- added an xml:lang="en" to the root element
- put in correct GraphViz pathnames
- changed the browser path to Mozilla (current system default)
I reran "run.bat" after each change/addition - the error message remained the same each time.

I have virtually no knowledge of Java and I'm unsure what other information might be helpful. I'll happily forward anything considered useful on request.

If this is a bug and a fix/patch needs testing, I'll be happy to do that also.

Regards,


Ken Cotterill.

Email: ken@me.com.au
Web: http://ken.me.com.au/
Received on Tuesday, 19 March 2002 03:10:47 GMT

This archive was generated by hypermail 2.2.0 + w3c-0.30 : Friday, 25 March 2005 11:19:57 GMT