W3C home > Mailing lists > Public > www-forms@w3.org > April 2005

Re: n00b question in xforms...

From: Fatal Error <fatalerror@sunnz.net>
Date: Sat, 02 Apr 2005 16:54:34 +1000
Message-ID: <424E41AA.4020205@sunnz.net>
To: www-forms@w3.org

I still don't get it... I have Flash installed on my FireFox, and that 
web page does indeed shows forms as flash, then why doesn't my xhtml 
file work? I have xform embeded into xhtml 1.1 and having mine-type as 
application/xml+xhtml... and btw, I am only looking at my file locally 
at this moment.

Micah Dubinko wrote:

> Hi Mr. Fatal Error,
>
> Have a look at http://xformsinstitute.com
>
> At this moment, ordinary XForms documents require a bit extra work to 
> run in Firefox or IE, one of
>
> * A browser plugin (like formsPlayer for IE or an XPI under 
> development for Firefox/Mozilla)
> * A server-side converter (like Orbeon or Chiba)
> * A client-side script (like the new FormFaces just announced here)
> * Flash (like DENG)
>
> XForms Institute uses the latter, and should "just work" if you have 
> Flash installed. Hopefully, it will give you a taste of what XForms is 
> like.
>
> .micah
>
> Fatal Error wrote:
>
>>
>> I saw xforms and w3c some days ago, and I would like to try it out, 
>> but I just don't really understand it... does it on any any web 
>> browsers now? I also tried use it in xhtml (using the name space 
>> thing), but nothing seems to work... I use FireFox to test things out 
>> most of the time.
>
>
Received on Saturday, 2 April 2005 06:54:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Saturday, 10 March 2012 06:22:00 GMT