W3C home > Mailing lists > Public > www-forms-editor@w3.org > August 2002

RE: XForms response to select1 vs. singleSelect

From: Piroumian Konstantin <KPiroumian@protek.com>
Date: Thu, 29 Aug 2002 11:07:34 +0400
Message-ID: <B6352CB87AA70442A1C6F49E6B658C9875BF26@POSTMAN.flagship.ru>
To: "'Klotz, Leigh'" <Leigh.Klotz@pahv.xerox.com>, "'www-forms-editor@w3.org'" <www-forms-editor@w3.org>

Thanks for clarification. 

Now I am aware of the reasons that lead to naming changes and I've forwarded
your response to Cocoon Dev list. I'll forward any input from there related
to this subject.

The XMLForm from Cocoon is not an official implementation of XForms, but we
are trying to keep the syntax as closer to XForms as possible and extend or
change it when necessary. So, we can live with the either names we decide at
cocoon-dev, though, I can't say that we are in favour of 'select1' element,
especially when there are so many names with other naming conventions from
XML Schema, XSLT, etc. that are used in XMLForm and Cocoon.

Regards,
  Konstantin

> -----Original Message-----
> From: Klotz, Leigh [mailto:Leigh.Klotz@pahv.xerox.com] 
> Sent: Wednesday, August 28, 2002 1:41 AM
> To: 'Piroumian Konstantin'; 'www-forms-editor@w3.org'
> Cc: Klotz, Leigh
> Subject: XForms response to select1 vs. singleSelect
> 
> 
> Thank you for your comments. 
> 
> I'd like to answer the issues you raise in your last message 
> (below) and ask
> you a question.
> 
> On <choose> and <choice>:
> - Either would be confused with the "choices" element -- one might
> reasonably believe that <choice> would always be a child element of
> <choices>.
> (Please see
> http://www.w3.org/TR/xforms/slice8.html#ui-common-elements-choices)
> - The pair of names "choice" and "select" doesn't really 
> indicate which is
> used for a single selection and which is used for multiple choice.
> (Or is it which is used for a single choice and which is used 
> for multiple
> selection?)
> 
> On the XHTML 2.0 issues raised:
> - Public discussion of XHTML takes place on www-html@w3.org, 
> so you can ask
> detailed questions about the h and section elements there.
> - We consulted with the HTML WG Chair, and he recommended that we keep
> <select> and <select1>.
> 
> It's difficult to come up with names that fit all constraints and make
> everyone happy.  Can you can live with the names in the current XForms
> working draft?
> 
> Thank you,
> Leigh.
> 
> 
> 
> -----Original Message-----
> From: Piroumian Konstantin [mailto:KPiroumian@protek.com] 
> Sent: Tuesday, August 27, 2002 12:51 AM
> To: 'Klotz, Leigh'; 'www-forms@w3.org'
> Subject: RE: Naming: select1 vs. singleSelect
> 
> 
> > From: Klotz, Leigh [mailto:Leigh.Klotz@pahv.xerox.com] 
> > 
> > Hello.
> > 
> > A strong goal of XForms integration with XHTML 2.0, and the 
> > XHTML Working
> > Group asked that we avoid hyphens and use only lowercase 
> > letters for element
> > and attribute names, which rules out both "selectOne" and 
> > "select-one".  
> 
> Ok. So what about a 'choice' or 'choose' (compare with 'select')?
> 
> > 
> > The all lower-case "selectone" is difficult to read in 
> > English, as it would
> > be pronounced "selec-tone", and is indeed used as such in 
> at least one
> > trademark (http://www.com-spec.com/selectone/).
> 
> I see.
> 
> > 
> > I don't think that trailing numerals in element names are 
> > unusual; see HTML
> > <h1>, <h2>, etc.
> 
> The <h1>, etc. elements are deprecated in XHTML 2.0 in favour 
> of <section>
> elements:
> http://www.w3.org/TR/2002/WD-xhtml2-20020805/mod-text.html#sec_8.18.
> 
> So, if XForms is going to be integrated with XHTML 2.0 then 
> it's better to
> avoid old-styled naming.
> 
> Regards,
>   Konstantin
> 
> > 
> > Thank you,
> > Leigh L. Klotz, Jr.
> > 
> > -----Original Message-----
> > From: Piroumian Konstantin [mailto:KPiroumian@protek.com] 
> > Sent: Monday, August 26, 2002 12:21 AM
> > To: 'www-forms@w3.org'
> > Subject: Naming: select1 vs. singleSelect
> > 
> > 
> > 
> > Hi!
> > 
> > What is the reason of using a name like 'select1' for single choice
> > selection element?
> > Don't you think that this kind of name is absolutely unusual 
> > in XML, XSL,
> > XHTML or HTML worlds? What's wrong with 'selectOne' or
> > 'singleSelect'/'multiSelect' names? Or maybe 'select-one' 
> > (using XSLT naming
> > convensions)?
> > 
> > Regards,
> >   Konstantin Piroumian 
> >   Ivelin Ivanov
> > --
> >   Apache Cocoon: http://xml.apache.org/cocoon
> >   kpiroumian@apache.org
> >   ivelin@apache.org
> > 
> 
Received on Thursday, 29 August 2002 03:08:34 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 10 June 2009 18:12:11 GMT