W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > June 2007

Re: Two renames

From: Jeni Tennison <jeni@jenitennison.com>
Date: Mon, 11 Jun 2007 19:09:35 +0100
Message-ID: <466D8FDF.8020406@jenitennison.com>
To: public-xml-processing-model-wg@w3.org

Norman Walsh wrote:
> / Jeni Tennison <jeni@jenitennison.com> was heard to say:
> | 2. From <p:document> to <p:load> because:
> |
> |    (a) confusion with <p:doc>
> |    (b) in a future version we might want to allow nested steps within
> | <p:input>; <p:document> does the same as the <p:load> step, so they
> | should be called the same thing
> Only if we get rid of p:load as a step. :-)

I definitely don't want to get rid of <p:load> as a step. If you don't 
want to rename <p:document> to <p:load> (you haven't said why not) then 
could we at least call it something that *won't* get confused with 
<p:doc> (which is the only element that breaks the 'no abbreviations' 
rule), such as <p:file>, or rename <p:doc> to <p:description> or something.

Jeni Tennison
Received on Monday, 11 June 2007 18:09:40 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:32:43 UTC