W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > November 2006

Re: Random things I noticed...

From: Innovimax SARL <innovimax@gmail.com>
Date: Tue, 28 Nov 2006 21:49:44 +0100
Message-ID: <546c6c1c0611281249r3bc3a581n59dab4523b1231ad@mail.gmail.com>
To: "Richard Tobin" <richard@inf.ed.ac.uk>
Cc: public-xml-processing-model-wg@w3.org

On 11/21/06, Richard Tobin <richard@inf.ed.ac.uk> wrote:
>
> ... while looking at the spec.
>
> "subpipeline" is used as a non-terminal in the syntax section, but not
> defined there.  There's a definition of the concept "subpipeline",
> but not of the term as used in the pseudo-grammar.  It should be
> something like
>
>   (p:step|p:for-each|p:viewport|p:choose|p:group|p:try)*

agree with just a slight little improvment
   (p:step|p:for-each|p:viewport|p:choose|p:group|p:try|anyOther)*

anyOther being an any element in another namespace


>
> Ports are named with the "port" attribute.  I think "name" is a much
> more intuitive name for the name (and is consistent with parameter).
>
> The attribute names "source" and "step" for binding inputs seem a poor
> pair to me.  Both in fact identify the source.  "source-port" and
> "source-step" would be better.

completly agree with both propositions

the more I read
        <p:output port="valid" step="val2" source="result"/>
the less I see which goes with which

        <p:output name="valid" source-step="val2" source-port="result"/>

is clearly more readable
but
        <p:output port="valid" source-step="val2" source-port="result"/>
could still be

Mohamed

-- 
Innovimax SARL
Consulting, Training & XML Development
9, impasse des Orteaux
75020 Paris
Tel : +33 8 72 475787
Fax : +33 1 4356 1746
http://www.innovimax.fr
RCS Paris 488.018.631
SARL au capital de 10.000 
Received on Tuesday, 28 November 2006 20:49:59 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:21:49 GMT