W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > November 2006

Random things I noticed...

From: Richard Tobin <richard@inf.ed.ac.uk>
Date: Tue, 21 Nov 2006 15:43:51 +0000 (GMT)
To: public-xml-processing-model-wg@w3.org
Message-Id: <20061121154351.A120016B062@macpro.inf.ed.ac.uk>

... while looking at the spec.

"subpipeline" is used as a non-terminal in the syntax section, but not
defined there.  There's a definition of the concept "subpipeline",
but not of the term as used in the pseudo-grammar.  It should be
something like

  (p:step|p:for-each|p:viewport|p:choose|p:group|p:try)*

Ports are named with the "port" attribute.  I think "name" is a much
more intuitive name for the name (and is consistent with parameter).

The attribute names "source" and "step" for binding inputs seem a poor
pair to me.  Both in fact identify the source.  "source-port" and
"source-step" would be better.

-- Richard
Received on Tuesday, 21 November 2006 15:43:34 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:21:49 GMT