public-webrtc-logs@w3.org from November 2018 by subject

[mediacapture-fromelement] Must the alpha channel be preserved, and what about encoding in an alpha-less format?

[mediacapture-image] new commits pushed by dontcallmedom

[mediacapture-main] How is adaptive frame rate to be handled? (#193)

[mediacapture-main] Make navigator.mediaDevices and navigator.getUserMedia SecureContext

[mediacapture-main] MediaStream in HTMLMediaElement: Does it have a first frame? (#555)

[mediacapture-main] new commits pushed by dontcallmedom

[mediacapture-main] new commits pushed by henbos

[mediacapture-main] new commits pushed by jan-ivar

[mediacapture-main] Pull Request: Define "camera" and "microphone" feature policies.

[mediacapture-main] should enumerateDevices list infrared cameras by default?

[mediacapture-main] should enumerateDevices list infrared cameras by default? (#553)

[mediacapture-main] Should getUserMedia be functional in SecureContext only?

[mediacapture-main] Should we allow empty string device IDs?

[mediacapture-main] Specify a way for WebDriver to add/remove/setup capture devices

[mediacapture-main] Specify a way for WebDriver to add/remove/setup capture devices (#554)

[mediacapture-main] What does it mean to 'combine' origins?

[mediacapture-output] new commits pushed by alvestrand

[mediacapture-output] new commits pushed by dontcallmedom

[mediacapture-output] Should setSinkId be functional in SecureContext only? (#78)

[mediacapture-record] new commits pushed by dontcallmedom

[mediacapture-record] Should MediaRecorderOptions fields be optional?

[mediacapture-record] Should MediaRecorderOptions members be optional?

[mediacapture-screen-share] Behavior for getDisplayMedia() and getDisplayMedia({}) should be the same (#65)

[mediacapture-screen-share] Constraints for Captured Display Surfaces should move to MediaTrackSettings

[mediacapture-screen-share] Define and rely on "display" permission-based feature policy.

[mediacapture-screen-share] Define and rely on "display-capture" permission-based feature policy.

[mediacapture-screen-share] define behaviors of all existing constraints that should apply in the screen capture

[mediacapture-screen-share] Define source pixel ratio, instead of relying on window.devicePixelRatio

[mediacapture-screen-share] Event for screen sharing

[mediacapture-screen-share] Forbid getDisplayMedia in top-level browsing context by default?

[mediacapture-screen-share] getDisplayMedia({video:false}) is interpreted as getDisplayMedia({video:true}) (#85)

[mediacapture-screen-share] Handle source device pixel ratio

[mediacapture-screen-share] Interaction with permissions API

[mediacapture-screen-share] List Constrainable Properties and their behavior.

[mediacapture-screen-share] Mention capture of audio (#78)

[mediacapture-screen-share] Need to add @uysalere as editor to this repo (#91)

[mediacapture-screen-share] non-top-level browsing contexts

[mediacapture-screen-share] Pull Request: Define and rely on "display" permission-based feature policy.

[mediacapture-screen-share] Pull Request: Define DisplayMediaStreamConstraints dictionary with video = true

[mediacapture-screen-share] Pull Request: Define source pixel ratio, instead of relying on window.devicePixelRatio

[mediacapture-screen-share] Should getDisplayMedia be functional in SecureContext only?

[mediacapture-screen-share] Should getDisplayMedia be moved to navigator.mediaDevices

[mediacapture-screen-share] Source pixel ratio of the video track

[mediacapture-screen-share] TAG review

[mediacapture-screen-share] TAG review (#59)

[mediacapture-screen-share] The user agent should be allowed to change sources after getDisplayMedia() resolves

[mediacapture-screen-share] Unclear how to aggregate windows or how to handle multiple windows/monitors (#71)

[webrtc-pc] Add preferredPayloadType to RTCRtpCodecCapability

[webrtc-pc] callback-based https://w3c.github.io/webrtc-pc/#method-extensions are not covered by WPT tests

[webrtc-pc] Describing which media description is offerer tagged. (#2001)

[webrtc-pc] Differences between pc.removeTrack(sender) and sender.replaceTrack(null)

[webrtc-pc] https://w3c.github.io/webrtc-pc/#method-extensions is not covered by WPT tests

[webrtc-pc] Make possible to select TURN allocation address family (to avoid IPv6 confusion)

[webrtc-pc] Make RTCDtlsTransport.getRemoteCertificates asynchronous? (#2034)

[webrtc-pc] Matching of origin for RTCCertificate objects is unclear

[webrtc-pc] More simulcast examples (#2035)

[webrtc-pc] new commits pushed by alvestrand

[webrtc-pc] new commits pushed by dontcallmedom

[webrtc-pc] new commits pushed by henbos

[webrtc-pc] Partially connected peerconnection might have "new" connectionstate.

[webrtc-pc] Partially connected peerconnection might have "new" connectionstate. (#2031)

[webrtc-pc] Pull Request: Make it clear that track IDs don't match on send and receive side

[webrtc-pc] Pull Request: Set [[Direction]] when doing SRD(answer).

[webrtc-pc] Pull Request: Specify how codec preferences is affected by direction.

[webrtc-pc] Redundant queuing in connection state computations.

[webrtc-pc] Regarding "a=msid"

[webrtc-pc] rename DtlsTransport.transport to DtlsTransport.iceTransport

[webrtc-pc] Rename sender.transport.transport to sender.transport.iceTransport?

[webrtc-pc] RTCDataChannel.bufferedAmountLowThreshold not handled correctly

[webrtc-pc] RTCIceTransport selected candidate pair behavior when changing state

[webrtc-pc] RTCRtpReceiver.getParameters() clarification

[webrtc-pc] RTCRtpReceiver.getParameters() clarification (#2032)

[webrtc-pc] RTCRtpReceiver.getStreams() and RTCRtpSender.getStreams()

[webrtc-pc] setCodecPreferences and RTX / RED / FEC codecs

[webrtc-pc] setCodecPreferences and transceiver direction change

[webrtc-pc] Should pc.removeTrack(sender) "reset" sending parameters in the transceiver?

[webrtc-pc] Should pc.removeTrack(sender) "reset" sending parameters in the transceiver? (#2025)

[webrtc-pc] Should peerIdentity mechanism be moved to webrtc-identity?

[webrtc-pc] Should we remove getDefaultIceServers?

[webrtc-pc] Should WPT webrtc folder be renamed to webrtc-pc

[webrtc-pc] special-casing of a=msid:-

[webrtc-pc] Start using new issue labels

[webrtc-pc] SVC Extension Specification (TPAC)

[webrtc-pc] transceiver.direction doesn’t respond, if out-of-sync.

[webrtc-pc] Using codecPayloadType with addTransceiver()

[webrtc-pc] Valid RID values mismatch between specs

[webrtc-stats] Add a note controlling exposure of remote candidate addresses

[webrtc-stats] Add a note controlling exposure of remote candidate addresses (#381)

[webrtc-stats] Add networkType fingerprint warning

[webrtc-stats] Add networkType fingerprint warning (#380)

[webrtc-stats] add rtt to rtcdatachannelsstats

[webrtc-stats] add stunserverconnectionstats

[webrtc-stats] Call out which stats are expected to trigger StatsEnded events (#366)

[webrtc-stats] Exposing RTCIceCandidateStats.networkType might trigger fingerprinting (#374)

[webrtc-stats] identifying the ice generation of a candidate pair (#358)

[webrtc-stats] Inconsistent usage of not applicable/not present (#373)

[webrtc-stats] Interframe delay stat for video receive stream.

[webrtc-stats] new commits pushed by dontcallmedom

[webrtc-stats] R (#383)

[webrtc-stats] RTCAudioHandlerStats: Signal/Noise Ratio (#383)

[webrtc-stats] RTCPeerConnectionStats appear redundant. Remove?

[webrtc-stats] RTCPeerConnectionStats appear redundant. Remove? (#382)

Closed: [mediacapture-main] enumerateDevices() doesn't mention how to handle OS device permissions

Closed: [mediacapture-main] should enumerateDevices list infrared cameras by default? (#553)

Closed: [mediacapture-main] Should getUserMedia be functional in SecureContext only?

Closed: [mediacapture-main] What does it mean to 'combine' origins?

Closed: [mediacapture-output] Should setSinkId be functional in SecureContext only? (#78)

Closed: [mediacapture-record] Should MediaRecorderOptions members be optional?

Closed: [mediacapture-screen-share] define behaviors of all existing constraints that should apply in the screen capture

Closed: [mediacapture-screen-share] Handle source device pixel ratio

Closed: [mediacapture-screen-share] Interaction with permissions API

Closed: [mediacapture-screen-share] Need to add @uysalere as editor to this repo (#91)

Closed: [mediacapture-screen-share] non-top-level browsing contexts

Closed: [mediacapture-screen-share] Should getDisplayMedia be functional in SecureContext only?

Closed: [mediacapture-screen-share] Should getDisplayMedia be moved to navigator.mediaDevices

Closed: [webrtc-pc] Regarding "a=msid"

Closed: [webrtc-pc] Rename sender.transport.transport to sender.transport.iceTransport?

Closed: [webrtc-pc] Should pc.removeTrack(sender) "reset" sending parameters in the transceiver? (#2025)

Closed: [webrtc-pc] Should peerIdentity mechanism be moved to webrtc-identity?

Closed: [webrtc-pc] special-casing of a=msid:-

Closed: [webrtc-stats] RTCPeerConnectionStats appear redundant. Remove? (#382)

Last message date: Friday, 30 November 2018 19:50:14 UTC