W3C home > Mailing lists > Public > public-webcrypto@w3.org > May 2014

Re: Is the "Key" interface name too generic?

From: Mark Watson <watsonm@netflix.com>
Date: Tue, 6 May 2014 10:16:46 -0700
Message-ID: <CAEnTvdCUMRd9E0qjLTY12FgS71U9av95kjPfEXVeOJdZD0EUAg@mail.gmail.com>
To: Boris Zbarsky <bzbarsky@mit.edu>
Cc: Richard Barnes <rlb@ipv.sx>, Ryan Sleevi <sleevi@google.com>, "public-webcrypto@w3.org" <public-webcrypto@w3.org>
On Tue, May 6, 2014 at 10:15 AM, Boris Zbarsky <bzbarsky@mit.edu> wrote:

> On 5/6/14, 1:09 PM, Mark Watson wrote:
>
>> Is the proposal just to change the name of the Key interface, or also to
>> change things like importKey -> importCryptoKey ?
>>
>
> My proposal was just to change the name of the interface.  importKey
> doesn't typically exist in isolation, and seeing crypto.subtle.importKey()
> is likely to clue people in that this might have something to do with
> crypto.


​Ok, so that proposal is fine with me. No particular opinion on the actual
name.​

...Mark



>
>
> -Boris
>
Received on Tuesday, 6 May 2014 17:17:13 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:17:22 UTC