W3C home > Mailing lists > Public > public-webcrypto@w3.org > May 2014

Re: Is the "Key" interface name too generic?

From: Boris Zbarsky <bzbarsky@MIT.EDU>
Date: Tue, 06 May 2014 13:15:02 -0400
Message-ID: <53691896.405@mit.edu>
To: Mark Watson <watsonm@netflix.com>, Richard Barnes <rlb@ipv.sx>
CC: Ryan Sleevi <sleevi@google.com>, "public-webcrypto@w3.org" <public-webcrypto@w3.org>
On 5/6/14, 1:09 PM, Mark Watson wrote:
> Is the proposal just to change the name of the Key interface, or also to
> change things like importKey -> importCryptoKey ?

My proposal was just to change the name of the interface.  importKey 
doesn't typically exist in isolation, and seeing 
crypto.subtle.importKey() is likely to clue people in that this might 
have something to do with crypto.

Received on Tuesday, 6 May 2014 17:15:34 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:17:22 UTC