W3C home > Mailing lists > Public > public-webcgm-wg@w3.org > December 2008

re[3]: Question about setView()

From: Lofton Henderson <lofton@rockynet.com>
Date: Wed, 10 Dec 2008 15:38:58 -0700
Message-Id: <5.1.0.14.2.20081210151208.022023a8@localhost>
To: WebCGM WG <public-webcgm-wg@w3.org>

Given no response to to the query (below) about reducing potential 
confusion by renaming the 'viewRect' parameter, here is the sentence that I 
am adding to the resolution of the DoC-12, the first part of the setView issue:

"The viewer shall fit the NVDC rectangle specified by the 'viewRect' 
parameter into the viewer's display rectangle and center it, while 
maintaining the aspect ratio of the 'viewRect' rectangle."

This is just a slight editorial variation on the resolution that we 
approved at the 04-dec telecon [1].  Therefore per the telecon resolution 
[1], I am listing DoC-12 as "Resolved in the WG", so speak up if you are 
not satisfied with the adjusted wording.

Regards,
-Lofton.

[1] http://lists.w3.org/Archives/Public/public-webcgm-wg/2008Dec/0038.html
[2] http://www.w3.org/TR/2008/WD-webcgm21-20080917/WebCGM21-DOM.html#setView

At 02:33 PM 12/4/2008 -0700, Lofton Henderson wrote:

>At 02:01 PM 12/4/2008 -0600, Don wrote:
>
>>Lofton,
>>
>>  >  Benoit or Don (or anyone) --
>>
>>  >  We have resolved this in concept -- yes, need to specify it.  I was
>>  >  entering it into the DoC and stumbled with wording.  Would one of you
>>  >  please send me some precise wording for [1]?
>>
>>  >  Taking off from Ben & Don suggestions, I started like this:  "The viewer
>>  >  shall fit the contents of the requested viewRect 
>> into >....what?....< and
>>  >  center it, while maintaining the aspect ratio of the viewRect."
>>
>>  >  It is the "....what?..." that I'm searching for.  Is it simply "viewer's
>>  >  rectangle" as in the (below) quoted zoom wording?  Or something more
>>  >  precise, like "view surface metafile display area"?  Or what?
>>
>>I believe we should use "the viewer's rectangle" to be consistent with
>>terminology
>>used in 3.2.4.3 where Move behavior is described.
>
>So accordingly the text based on Ben & Don suggestions would become:
>
>[[[
>"The viewer shall fit the contents of the requested viewRect into the 
>viewer's rectangle and center it, while maintaining the aspect ratio of 
>the requested viewRect."
>]]]
>
>That seems to have potential to invite confusion, since the input 
>parameter name is viewRect and we are mapping it into the viewers 
>rectangle.  (Huh?)
>
>The viewRect is really a window in the NVDC space, and is referred to as 
>such in ISO graphics standards.  Whereas the "viewer's rectangle" is a 
>viewport in DC space.  Maybe the parameter should be named viewWindow or 
>something.  Or newNvdcWindow.  Or ...?
>
>Is anyone else uncomfortable with the almost identical terminology on both 
>sides of the mapping description?
>
>-Lofton.
>
>
>
>>  >  I seem to recall some discussion of this once, but can't find it 
>> now.  (We
>>  >  were playing with words like viewport, viewWindow, etc, for what is now
>>  >  viewRect?)
>>
>>  >  Regards,
>>  >  -Lofton.
>>
>>  >  [1]
>>  >  http://www.w3.org/TR/2008/WD-webcgm21-20080917/WebCGM21-DOM.html#setView
>>
>>
>>  >  At 09:31 AM 11/19/2008 -0600, Don wrote:
>>
>>  >  >Benoit
>>  >  >
>>  >  >  >  I think some wording like the 'zoom' object behavior would  be
>>  >  > sufficient:
>>  >  >  >
>>  >  >  >  zoom The viewer shall fit the target  rectangle of the
>>  >  > selected  object(s)
>>  >  >  >  into the viewer's rectangle and center it.
>>  >  >
>>  >  >I think that would be adequate if we add "while maintaining the aspect
>>  >  >ratio of..."
>>  >  >
>>  >  >  >
>>  >  >  >  Benoit
>>  >  >  >
>>  >  >  >
>>  >  >  >  From: Lofton Henderson  [mailto:lofton@rockynet.com]
>>  >  >  >  Sent: Tuesday, November 18, 2008 7:20  PM
>>  >  >  >  To: Bezaire, Benoit; WebCGM WG
>>  >  >  >  Subject: RE: Question  about setView()
>>  >  >
>>  >  >  >
>>  >  >  >  At 11:51 AM 11/18/2008 -0500, Bezaire, Benoit wrote:
>>  >  >  >  Also, there is nothing in the wording explaining how to handle 
>> view
>>  >  >  >  rectangles which have a different aspect ratio than the viewer's
>>  >  > viewport.
>>  >  >  >  Which will happen in 99% of the cases.
>>  >  >  >  Good point.   I raised this myself some time back, and it got lost
>>  >  before
>>  >  >  >  any  resolution.
>>  >  >
>>  >  >  >  There is some guidance in the stuff of section 3.4,  where we have
>>  >  > <param>s
>>  >  >  >  that specify mapping, halign, valign of the picture  into the
>>  >  <object>'s
>>  >  >  >  rectangle.  I think something similar is  reasonable here.
>>  >  >  >  (Alternatively, if we don't want the mapping options, we  have to
>>  >  specify
>>  >  >  >  how it happens unambiguously.)
>>  >  >
>>  >  >  >  -Lofton.
>>  >  >
>>  >  >
>>  >  >  >  From: public-webcgm-wg-request@w3.org
>>  >  >  >  [mailto:public-webcgm-wg-request@w3.org] On Behalf Of  Bezaire,
>>  >  Benoit
>>  >  >  >  Sent: Tuesday, November 18, 2008 8:58  AM
>>  >  >  >  To: WebCGM WG
>>  >  >  >  Subject: Question about  setView()
>>  >  >
>>  >  >  >  I'm wondering if the wording  of setView() is not a bit short? The
>>  >  draft
>>  >  >  >  doesn't say anything about invalid  rectangles being passed in for
>>  >  >  >  example.
>>  >  >  >
>>  >  >  >  Should more feedback be sent to the user? Currently, the function
>>  >  >  >  prototype has a void return type. Should we change that to a 
>> boolean
>>  >  or
>>  >  >  >  something else? or throw an exception perhaps.
>>  >  >  >
>>  >  >  >  I also question the possibility of a major scale change, 
>> ex:  scaling
>>  >
>>  >  > in by
>>  >  >  >  a factor of 100 (and loosing sight of the overall 
>> picture).  Should
>>  >  the
>>  >  >  >  user be told that such a change occurred?
>>  >  >  >
>>  >  >  >  Thoughts?
>>  >  >  >  Benoit.
>
>
>
Received on Wednesday, 10 December 2008 22:41:08 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 10 December 2008 22:41:09 GMT