W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: [IndexedDB] Should removeIndex/ObjectStore be renamed to match s/remove/delete/ elsewhere?

From: Jonas Sicking <jonas@sicking.cc>
Date: Tue, 19 Oct 2010 18:06:58 -0700
Message-ID: <AANLkTi=aBbE29ObD96g1CL+d=CoGi90PRf67v8YSZABZ@mail.gmail.com>
To: Jeremy Orlow <jorlow@chromium.org>
Cc: public-webapps WG <public-webapps@w3.org>
On Tue, Oct 19, 2010 at 3:39 PM, Jeremy Orlow <jorlow@chromium.org> wrote:
> Jonas just checked in a change to replace .remove() with .delete() (amongst
> other changes we agreed upon a while ago).  In light of that, does it make
> sense for removeIndex and removeObjectStore to be renamed to deleteIndex and
> deleteObjectStore to match the new naming?  I don't care a whole lot, but it
> seems like that'd make things more consistent.

Heh, I was thinking about exactly that when I made the change. I don't
feel strongly but consistency is always nice.

/ Jonas
Received on Wednesday, 20 October 2010 01:07:55 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:41 GMT