W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2010

Re: [IndexedDB] Should removeIndex/ObjectStore be renamed to match s/remove/delete/ elsewhere?

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Tue, 19 Oct 2010 17:45:12 -0700
Message-ID: <AANLkTik96CbHU1fd9KsrLL4wNOhMjJJFO2AQgCLCQkat@mail.gmail.com>
To: Jeremy Orlow <jorlow@chromium.org>
Cc: public-webapps WG <public-webapps@w3.org>
On Tue, Oct 19, 2010 at 3:39 PM, Jeremy Orlow <jorlow@chromium.org> wrote:
> Jonas just checked in a change to replace .remove() with .delete() (amongst
> other changes we agreed upon a while ago).  In light of that, does it make
> sense for removeIndex and removeObjectStore to be renamed to deleteIndex and
> deleteObjectStore to match the new naming?  I don't care a whole lot, but it
> seems like that'd make things more consistent.

Yes.  All of the action verbs in the API should be consistent.
Anything else is gratuitous inconsistency that makes it hard to use
the API from memory.

~TJ
Received on Wednesday, 20 October 2010 00:46:05 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:41 GMT