W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2010

Re: Seeking pre-LCWD comments for Indexed Database API; deadline February 2

From: Jeremy Orlow <jorlow@chromium.org>
Date: Tue, 15 Jun 2010 19:40:46 +0100
Message-ID: <AANLkTim4MkZGvKd_xi-tnVv7rDsSHOFNMhGXTrjHwAuK@mail.gmail.com>
To: Jonas Sicking <jonas@sicking.cc>
Cc: Pablo Castro <Pablo.Castro@microsoft.com>, Kris Zyp <kris@sitepen.com>, WebApps WG <public-webapps@w3.org>
On Tue, Jun 15, 2010 at 7:36 PM, Jonas Sicking <jonas@sicking.cc> wrote:

> On Mon, Jun 14, 2010 at 11:20 PM, Pablo Castro
> <Pablo.Castro@microsoft.com> wrote:
> >>> We developed a similar trick where we can indicate in the IDL that
> different names are used for scripted languages and for compiled languages.
> >
> >>> So all in all I believe this problem can be overcome. I prefer to focus
> on making the JS API be the best it can be, and let other languages take a
> back seat. As long as it's solvable without too much of an issue (such as
> large performance penalties) in other languages.
> >
> > I agree we can sort this out and certainly limitations on the
> implementation language shouldn't surface here. The issue is more whether
> folks care about a C++ binding (or some other language with a similar issue)
> where we'll have to have a different name for this method.
> >
> > Even though I've been bringing this up I'm ok with keeping delete(), I
> just want to make sure we understand all the implications that come with
> that.
>
> I'm also ok with keeping delete(), as well as continue(). This despite
> realizing that it might mean that different C++ implementations might
> map these names differently into C++.
>

Isn't continue a _JS_ reserved word though?
Received on Tuesday, 15 June 2010 18:41:36 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:39 GMT