Re: XMLHttpRequest.responseBlob

On Tue, Apr 27, 2010 at 12:12 AM, Simon Pieters <simonp@opera.com> wrote:
>>> I would rather keep consistency with the hundreds of other properties
>>> that use lower case name, than the single one that use upper case.
>
> I would rather have all attributes with the same name use the same case.
>
>
>>> Add
>>> to that the fact that Document.URL is fairly rarely used.
>
> It's more used than referrer, lastModified, charset, characterSet,
> defaultCharset, dir, head, embeds, plugins, links, scripts, innerHTML,
> activeElement, designMode and commands on HTMLDocument according to google
> code search.

Why restrict yourself to the HTMLDocument interface? There are
literally hundreds of properties in the DOM. Every single one uses a
camelCase naming scheme for properties. Names starting with upper case
is only used for "interface" names. Same thing with all javascript
libraries that I can think of off the top of my head. And same thing
with all built in properties defined in EMCAScript.

The only exception that the web depends on is Document.URL.

I don't think we can give a property an all uppercase name and claim
that we're following any sort of established pattern.

/ Jonas

Received on Tuesday, 27 April 2010 08:00:54 UTC