W3C home > Mailing lists > Public > public-webapi@w3.org > July 2007

Re: Selectors API Method Names

From: Jonas Sicking <jonas@sicking.cc>
Date: Mon, 02 Jul 2007 17:45:01 -0700
Message-ID: <46899C0D.5080309@sicking.cc>
To: Maciej Stachowiak <mjs@apple.com>
CC: Charles McCathieNevile <chaals@opera.com>, Doug Schepers <doug.schepers@vectoreal.com>, public-webapi <public-webapi@w3.org>

Maciej Stachowiak wrote:
> 
> 
> On Jul 2, 2007, at 3:50 PM, Charles McCathieNevile wrote:
> 
>>
>> On Mon, 02 Jul 2007 20:17:40 +0200, Doug Schepers 
>> <doug.schepers@vectoreal.com> wrote:
>>
>>> Hi-
>>>
>>> Maciej Stachowiak wrote:
>>>>  I don't have a strong objection either way, but I think the case 
>>>> against Lachy's original names (selectElement, etc) has been laid 
>>>> out more clearly than the case against cssQuery. I think 
>>>> selectorQuery (as suggested in follow-ups) would also be ok.
>>>
>>> I think that the chief problem with cssQuery*() for me is that it is 
>>> rather confusing.  Such a name would indicate functionality related 
>>> to CSS (that is, something presentational or style-oriented), rather 
>>> than the accident of a historical relationship.  It totally fails the 
>>> criteria of being functionally descriptive, which selectElement() 
>>> meets (other merits notwithstanding); this is a point on which I 
>>> think we can build consensus and compromise (and hopefully a speedy 
>>> resolution).
>>>
>>> Similarly, with selectorQuery() (which is better), you lose the verby 
>>> "action word" of the existing naming convention (getAByB); 
>>> selectorQuery sounds more like a property than a method.
>>>
>>> Frankly, I'm not a fan of any of the present crop of names, but in 
>>> the interest of keeping forward momentum, I least object to what we 
>>> currently have, selectElement*().
>>
>> Thank you Doug for so eloquently stating the details of my objection. 
>> As it happens, I agree with you that I would rather move forward with 
>> the consensus on selectElement*, if we establish that, than keep 
>> chasing round for new names.
> 
> I really think the confusability of this with 
> selectNodes/selectSingleNode is a significant problem. matchSelector  or 
> querySelector doesn't have this problem, and also doesn't have the 
> problems of cssQuery (slightly inaccurate mention of css, doesn't sound 
> like a verb phrase).
> 
> But I won't stand in the way of an editorial decision on this one.

Same feelings here. Except that IMHO matchSelector sounds like something 
that would return a bool indicating if an element matches the given 
selector.

So querySelector is the one I like the most so far (except for 
getElementsBySelector, but I'm not even going to suggest that one :) )

/ Jonas
Received on Tuesday, 3 July 2007 00:45:30 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:57 GMT