W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API naming

From: Maciej Stachowiak <mjs@apple.com>
Date: Fri, 26 Jan 2007 19:06:04 -0800
Message-Id: <631D8EE0-0AA5-4908-B7C5-622AF43BEF26@apple.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
To: Anne van Kesteren <annevk@opera.com>

On Jan 25, 2007, at 10:26 AM, Anne van Kesteren wrote:

> So the WG just discussed in a little over an hour a counter  
> proposal to the current naming[1] and came up with:
>  * getElementBySelectors()
>  * getElementListBySelectors()
> I don't really like them. Supposedly I'm to edit the draft to  
> reflect this...

These are all three of incredibly long, inconsistent with the naming  
of current get-family methods (there's nothing named  
getElementListBy...), and somewhat unclear about what the method  
really does (sounds like "Selectors" would mean you give it an array  
of selectors or otherwise pass more than one).

Congratulations, design by committee has once again failed to meet  
anyone's requirements (in other words, I object to these names).

Received on Saturday, 27 January 2007 03:06:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC